This device requires Flash 9 to customize our products